Log In Issues
Incident Report for Vimeo
Resolved
We apologize for the inconvenience. The previous log in issues affecting vimeo.com have now been resolved. It is now safe to try logging into your Vimeo account again.
Posted 5 months ago. Apr 23, 2019 - 15:31 EDT
Investigating
We are currently investigating an issue which prevents users from logging into Vimeo.com. Users who are already logged in should not be affected. We hope to have a fix rolled out soon and will be sure to keep you posted. Thank you for your patience in the meantime!
Posted 5 months ago. Apr 23, 2019 - 15:12 EDT
This incident affected: Website.