Help Center outage
Incident Report for Vimeo
Resolved
We're back! Thanks for your patience.
Posted about 2 years ago. Mar 15, 2017 - 19:59 EDT
Identified
Due to a service outage with our service provider, the Vimeo Help Center is not currently accessible. Please email support@vimeo.com if you need help and we'll get back to you ASAP.
Posted about 2 years ago. Mar 15, 2017 - 15:52 EDT