Upload issues
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 18:18 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2022 - 18:05 EDT
Update
We are continuing to investigate this issue.
Posted Jun 29, 2022 - 17:32 EDT
Investigating
We are currently investigating this issue.
Posted Jun 29, 2022 - 17:19 EDT
This incident affected: Upload.