Intermittent site issues
Incident Report for Vimeo
Resolved
Thank you for your patience! Our engineers were able to resolve this issue and the site should be operating normally.
Posted over 2 years ago. Sep 02, 2016 - 15:50 EDT
Monitoring
Vimeo.com is back up and running. We're monitoring things to make sure we remain stable.
Posted over 2 years ago. Sep 02, 2016 - 14:47 EDT
Investigating
We are currently experiencing intermittent issues on Vimeo.com. Our engineers are working on getting things fixed as soon as possible. We'll update everyone as soon as we have additional information. Thank you for your patience!
Posted over 2 years ago. Sep 02, 2016 - 13:56 EDT