Videos getting stuck in upload pending state

Incident Report for Vimeo

Postmortem

On Wednesday, May 21, 2025, from 1:45 to 5:00 AM EDT, Vimeo users experienced delays in video uploads, transcoding jobs, transcriptions, and related tasks. A small number of transcoding jobs failed during this time and were successfully reprocessed later in the morning.

The incident was the result of delays in processing status notifications for new uploads.

In response to this outage, we've implemented new systems to alert us of notification backlogs sooner. We've also implemented server-side changes to make the affected service more resilient to atypical behavior.

Posted May 27, 2025 - 20:22 EDT

Resolved

This incident has been resolved.
Posted May 21, 2025 - 05:57 EDT

Update

We are continuing to monitor for any further issues.
Posted May 21, 2025 - 04:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2025 - 04:50 EDT

Identified

The issue has been identified, and a fix is being implemented.
Posted May 21, 2025 - 03:20 EDT

Update

Some users are experiencing videos getting stuck in the upload pending state for direct uploads. This is being investigated as a priority.
Posted May 21, 2025 - 03:11 EDT

Investigating

We are currently experiencing an outage where recorded videos are stuck in the upload pending state. This issue is being investigated as a priority.
Posted May 21, 2025 - 02:04 EDT
This incident affected: Website, Create, and Record.