Platform-wide issues
Incident Report for Vimeo
Resolved
Our engineers have confirmed the main platform issues have been resolved. There are some residual issues with search on Vimeo that they're continuing to work through.
Posted 3 months ago. Jun 02, 2019 - 20:27 EDT
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Jun 02, 2019 - 19:09 EDT
Monitoring
Our systems have recovered. Our engineers will continue to monitor, but believe the platform-wide issues have been resolved.
Posted 3 months ago. Jun 02, 2019 - 19:04 EDT
Investigating
We're currently experiencing platform-wide issues, including the Vimeo player and API. Our engineers are investigating and we will provide an update as soon as possible.
Posted 4 months ago. Jun 02, 2019 - 15:15 EDT
This incident affected: Website, Billing, On-Site Player, Embedded Player, Upload, Conversion, API, Mobile/ TV Apps, Stats, and Support Systems.