Issue with Vimeo on Demand analytics (subscriptions) and billing.

Incident Report for Vimeo

Update

We are continuing to investigate this issue. Single promo codes are now working. We are actively working on batch promo codes and VIP access codes.
Posted Apr 16, 2025 - 09:51 EDT

Investigating

We are currently investigating the issue.
Posted Apr 03, 2025 - 14:31 EDT
This incident affects: Billing and VOD Analytics.