Vimeo Site Outage
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 12:48 EDT
Monitoring
Thank you for your patience. Our development team were able to fix the issue and all components of the site should be operational. We will continue to monitor closely.
Posted Apr 15, 2020 - 12:01 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 15, 2020 - 11:43 EDT
Update
We are continuing to investigate this issue.
Posted Apr 15, 2020 - 11:35 EDT
Investigating
We are currently seeing site outages across Vimeo. Our development team is investigating and we will update once we know more.
Posted Apr 15, 2020 - 11:34 EDT
This incident affected: Website, Billing, On-Site Player, Embedded Player, Upload, Conversion, API, Mobile/ TV Apps, Live Analytics, Support Systems, and Live streaming features.