Intermittent issues with Billing pages

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Jul 31, 2024 - 16:27 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2024 - 16:20 EDT

Investigating

Some customers may experience issues accessing their billing page and see intermittent issues completing checkout. Our engineering teams are investigating the issue and will update in the next 60 minutes.
Posted Jul 31, 2024 - 15:57 EDT
This incident affected: Billing.