Playback issues

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 13:44 EDT

Update

A fix has been implemented and we are seeing recovery across the players.
Posted Jul 29, 2026 - 13:16 EDT

Identified

We have implemented a fix and are monitoring.
Posted Jul 29, 2026 - 12:52 EDT

Update

We are continuing to investigate this issue.
Posted Jul 29, 2026 - 12:44 EDT

Update

We are experiencing partial outages to our players and are working to implement a fix
Posted Jul 29, 2026 - 12:43 EDT

Investigating

We are currently investigating this issue.
Posted Jul 29, 2026 - 12:38 EDT
This incident affected: On-Site Player and Embedded Player.