Support system intermittent outage
Incident Report for Vimeo
Resolved
The outage with our Help Desk service provider has been resolved. Thank you for your patience.
Posted 2 days ago. Sep 13, 2019 - 14:39 EDT
Monitoring
Our support service provider's performance is recovering. We're back in the queues and continuing to monitor the situation.
Posted 2 days ago. Sep 13, 2019 - 14:10 EDT
Investigating
Due to a service outage with our service provider, there might be a delay in our response times and intermittent outages of our help center. If you've submitted a support request, we'll get back to you ASAP.
Posted 2 days ago. Sep 13, 2019 - 12:40 EDT
This incident affected: Support Systems.