China delivery domains under videoji.cn are down

Incident Report for Vimeo

Postmortem

What happened

On August 19, between approximately 12:45 PM and 2:00 PM EDT, Vimeo Enterprise customers were unable to access their video libraries or play videos through our China delivery solution.

What caused it

Our third-party hosting provider experienced an outage that disrupted data access between Mainland China and other regions. 

How we responded

Our internal monitoring systems brought this issue to our attention. We began investigating it immediately, determined that the cause was external, and confirmed the outage with our provider once their ability to provide status updates was restored. 

What we’re doing to prevent a recurrence

While outages caused by external infrastructure are outside our direct control, we’re improving our monitoring to include a continuous health check on the provider’s service, so that we know from the outset whether the outage is external.

Posted Aug 19, 2025 - 17:28 EDT

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 14:00 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 19, 2025 - 13:55 EDT

Investigating

We are currently investigating this issue.
Posted Aug 19, 2025 - 13:46 EDT