Videos failing to play
Incident Report for Vimeo
Resolved
Our developers have identified the issue and implemented a fix. All videos should now be playing as expected. Thanks for bearing with us!
Posted about 1 year ago. Jul 11, 2018 - 15:35 EDT
Investigating
We're currently investigating an issue preventing playback for certain videos on vimeo.com and while embedded. Our developers are on the case and hope to have a solution in place as soon as possible. We appreciate your patience while we sort this out.
Posted about 1 year ago. Jul 11, 2018 - 14:38 EDT
This incident affected: On-Site Player and Embedded Player.