Non Live Analytics is down for 50% of users.
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 09:38 EDT
Investigating
We are currently investigating this issue.
Posted Aug 05, 2022 - 09:28 EDT