Creating and editing videos failing to find previous uploads

Incident Report for Vimeo

Resolved

This incident has been resolved, and prior uploads are now visible when creating and editing videos. Our sincere apologies for the delay.
Posted Sep 24, 2025 - 16:23 EDT

Update

Thanks for your patience while we continue to investigate this issue. To clarify, both web and mobile are affected by this issue, contrary to the initial report.

Notably, this only affects media assets when creating and editing videos. General site uploads are not impacted.
Posted Sep 23, 2025 - 09:01 EDT

Investigating

We are currently investigating an issue where video and image uploads are failing to load when creating and editing videos on the web. Mobile is unaffected.
Posted Sep 22, 2025 - 21:32 EDT
This incident affected: Create and Transcript Editor.