Storage Provider Outage
Incident Report for Vimeo
Resolved
Our storage provider has confirmed that the issue has been resolved. We will continue monitoring on our end as well to ensure ongoing stability. Upload, thumbnails, and player performance should now be functioning as expected.
Posted 12 days ago. Mar 13, 2019 - 02:25 EDT
Monitoring
Our systems are currently recovering and slowly returning to normal. We will continue to monitor to ensure ongoing stability. More updates to come!
Posted 12 days ago. Mar 13, 2019 - 02:02 EDT
Identified
Our provider has identified the issue and is continuing to work on a solution. We hope to have another update to share with you soon.
Posted 12 days ago. Mar 13, 2019 - 00:29 EDT
Investigating
We are currently investigating a widespread issue affecting our storage provider which can manifest in the following ways:

1) Thumbnails may fail to load
2) Degraded playback performance; more buffering events may occur during certain playback sessions and some videos may fail to load entirely.
3) Upload and conversion may unexpectedly fail for certain videos.

We are working to resolve these issues with our provider as quickly as possible. Thank you for your patience and understanding while we sort this out.
Posted 12 days ago. Mar 12, 2019 - 23:10 EDT
This incident affected: Website, On-Site Player, Embedded Player, Upload, and Conversion.