Vimeo Editor Page Intermittently Not Loading

Incident Report for Vimeo

Resolved

This incident is now fully resolved.
Posted Oct 02, 2025 - 13:58 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 02, 2025 - 09:01 EDT

Monitoring

We've deployed a fix that has dramatically reduced the rate of errors, and we're continuing to monitor for progress. Thanks for your continued patience.
Posted Oct 02, 2025 - 08:57 EDT

Update

We are continuing to investigate this issue.
Posted Oct 01, 2025 - 22:09 EDT

Investigating

We are continuing to investigate this issue.
Posted Oct 01, 2025 - 20:51 EDT

Identified

https://vimeo.com/create/edit is intermittently not loading.
Posted Oct 01, 2025 - 18:02 EDT
This incident affected: Website, Editor, and Interactive.