Vimeo site is down

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Jun 07, 2025 - 06:26 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 07, 2025 - 06:12 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 07, 2025 - 06:01 EDT

Update

Logged in users are not able to access Vimeo site including Vimeo support contact form. Site is accessible for logged out users and on mobile apps.
Posted Jun 07, 2025 - 02:24 EDT

Investigating

We are currently investigating this issue.
Posted Jun 07, 2025 - 02:21 EDT
This incident affected: Website.