Classic Interactive Downtime

Incident Report for Vimeo

Monitoring

The fix has been implemented, and Interactive Editor (Classic) is now available in 93% of geographic locations.

For the remaining locations, it may take up to 72 hours for DNS changes to propagate. As a workaround, it's possible to use Interactive Editor (Classic) in these regions through a VPN.
Posted Sep 08, 2025 - 03:43 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 05, 2025 - 12:37 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 05, 2025 - 11:11 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 05, 2025 - 10:49 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 05, 2025 - 10:24 EDT

Update

Interactive Editor (Classic) is down
Posted Sep 05, 2025 - 08:37 EDT

Investigating

We are currently investigating this issue.
Posted Sep 05, 2025 - 08:35 EDT