Vimeo.com outage
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Dec 20, 2023 - 13:45 EST
Update
We are continuing to monitor for any further issues.
Posted Dec 20, 2023 - 13:38 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 20, 2023 - 13:29 EST
Investigating
Hi All,

We are experiencing an issue on our Vimeo.com site wherein a few pages aren't loading. This is being investigated on priority.

We will update you on the status shortly.

Thanks,
Posted Dec 20, 2023 - 13:24 EST
This incident affected: Website.