Vimeo Create Outage - unable to create videos

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Jul 11, 2024 - 04:20 EDT

Investigating

We are currently investigating this issue.
Posted Jul 11, 2024 - 02:44 EDT
This incident affected: Create.