Partial Site Outage
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 10:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2020 - 10:42 EDT
Investigating
We are currently investigating an issue causing some pages on Vimeo.com not to load properly. Our team is working to find the cause as quickly as possible.
Posted Apr 08, 2020 - 10:20 EDT
This incident affected: Website and Live streaming features.