Increased Upload Failure Rates

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 14:46 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2025 - 14:26 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 18, 2025 - 12:33 EDT

Identified

An underlying issue with our cloud provider has been identified. We have directed resources away from the affected region to compensate, but error rates may continue to be slightly elevated from normal.
Posted Jul 18, 2025 - 12:07 EDT

Investigating

We are currently investigating an issue with increase upload failure rates.
Posted Jul 18, 2025 - 11:41 EDT
This incident affected: Upload.