Showcases are showing "this is private" warning unexpectedly.

Incident Report for Vimeo

Resolved

Showcases are now fully operational.
Posted Aug 19, 2025 - 18:22 EDT

Identified

We've identified the issue and deployed a fix.
Posted Aug 19, 2025 - 17:54 EDT

Update

Some users are experiencing authorization errors with Showcases that should be publicly available. We're currently investigating...
Posted Aug 19, 2025 - 17:41 EDT

Investigating

We are currently investigating this issue.
Posted Aug 19, 2025 - 17:40 EDT
This incident affected: Website.