Processing Delays

Incident Report for Vimeo

Resolved

Upload and video processing are performing normally.
Posted Jun 13, 2025 - 18:59 EDT

Update

We are still progressing through the final steps of the backlog recovery.
Posted Jun 13, 2025 - 15:25 EDT

Identified

We have identified the issue. New uploads will be processed immediately, however, some delays still exist for videos uploaded within the last hour. That backlog is currently being worked on.
Posted Jun 13, 2025 - 12:45 EDT

Investigating

We are currently investigating an issue with video processing and creation delays in a single region.
Posted Jun 13, 2025 - 11:42 EDT
This incident affected: Upload and Create.