Issues loading Player

Incident Report for Vimeo

Resolved

Player is now functional.
Posted Apr 14, 2026 - 13:49 EDT

Investigating

We are reinvestigating an issue with the Player.
Posted Apr 14, 2026 - 13:25 EDT

Update

We have implemented the fix and are seeing recovery.
Posted Apr 14, 2026 - 13:13 EDT

Identified

We have identified the issue and are implementing a fix.
Posted Apr 14, 2026 - 13:01 EDT

Update

We have identified an issue with the Player and are investigating.
Posted Apr 14, 2026 - 12:43 EDT

Investigating

We are currently investigating this issue.
Posted Apr 14, 2026 - 12:42 EDT
This incident affected: On-Site Player and Embedded Player.