Livestream Studio is unable to establish connection to Vimeo

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 08:01 EDT

Update

Current Status: Monitoring
Current Action: We have implemented fix for issues with Livestream Studio.
Posted Oct 16, 2025 - 07:34 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 16, 2025 - 07:29 EDT

Update

Current Status: Investigating
Current Action: We have identified issues with Livestream Studio. We are investigating and will update you here when we have more information.
Posted Oct 16, 2025 - 07:06 EDT

Investigating

We are currently investigating this issue.
Posted Oct 16, 2025 - 06:57 EDT