Vimeo Logout Home Page and Marketing Pages are not loading
Incident Report for Vimeo
Resolved
The issue was with rollouts on 5/24/23. We have restored an older build to resolve the problem.
Posted May 25, 2023 - 03:16 EDT
Investigating
there is currently an issue with accessing the logout home page and marketing pages on Vimeo
Posted May 25, 2023 - 01:58 EDT
This incident affected: Website.