Uploading video results in Technical Difficulties error
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 22:15 EDT
Investigating
We are aware of an uploading error that happens when using the "new video" menu located in the top right corner of the Video Manage page. Using this menu to upload a video results in a "technical difficulties" error. For now please use the other "new video" menu located on the top left side of the Video Manage page. We are investigating this error and working on a solution.
Posted Oct 07, 2021 - 20:52 EDT
This incident affected: Upload.