AI translations and Highlights are down

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 08:19 EDT

Identified

AI translations and highlights services are not working for all users. We have identified the problem and are working towards a resolutions.
Posted Jun 13, 2025 - 05:44 EDT