Failing to load player.js

Incident Report for Vimeo

Resolved

Monitors are clear and we’re resolving this incident.
Posted Oct 21, 2025 - 15:56 EDT

Update

We've confirmed that player.js is now successfully loading. We'll continue monitoring.
Posted Oct 21, 2025 - 09:50 EDT

Identified

We've taken action to circumvent the problem and we are seeing signs of recovery.
Posted Oct 21, 2025 - 09:45 EDT

Update

We’re investigating issues where loading player.js fails. This may affect playback in scenarios where customers are directly loading our Player library. Playback on the web and in embeds are unaffected.
Posted Oct 21, 2025 - 08:30 EDT

Investigating

We are currently investigating this issue.
Posted Oct 21, 2025 - 08:27 EDT