Vimeo.com is not accessible for logged out users

Incident Report for Vimeo

Postmortem

What happened

On July 31, between approximately 12:30 AM and 2:00 AM EDT, some logged-out Vimeo users encountered an issue when visiting the Vimeo home page. Instead of the expected content, impacted users received a blank screen with a brief error message. 

What caused it

Corrupted memory on the server side caused some isolated web server processes to fail. As a result, requests for the logged-out Vimeo home page that relied on these processes resulted in the error message. 

How we responded

We became aware of the outage within 30 minutes of the initial event and immediately began investigating. Once we confirmed the issue, we applied a manual fix to restore normal functionality. 

What we’re doing to prevent a recurrence

We’re improving our internal reporting to alert us to similar conditions sooner. We’re also making sure that future errors of this type generate our standard HTTP 500 error page instead of a blank screen with a technical readout.

Posted Aug 08, 2025 - 16:35 EDT

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 04:43 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 31, 2025 - 03:23 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 31, 2025 - 02:07 EDT

Investigating

We have identified the issue and working on a fix.
Posted Jul 31, 2025 - 01:16 EDT
This incident affected: Website.