Articles not loading in help center (vimeo.com/help)
Incident Report for Vimeo
Resolved
Our help center is now back up and running.
Posted 11 months ago. Oct 18, 2018 - 16:46 EDT
Investigating
We are aware that our help center page (vimeo.com/help) is currently not loading any articles. We are working on getting this fixed ASAP.
Posted 11 months ago. Oct 18, 2018 - 12:36 EDT
This incident affected: Support Systems.