Some Videos Are Stuck Processing/Optimizing

Incident Report for Vimeo

Resolved

Videos have been recovered from the affected time range. Systems to continue to operate normally.
Posted Jul 26, 2025 - 18:48 EDT

Update

Vimeo Engineers continue to work on recovering uploads that are stuck optimizing from an earlier partial outage.
Posted Jul 26, 2025 - 15:48 EDT

Monitoring

From 4:12am EDT to 11:42 am EDT some uploads might have gotten stuck in processing/optimizing. Engineers are currently recovering those videos, but the system is back to normal at this time.
Posted Jul 26, 2025 - 11:51 EDT
This incident affected: Upload.