Transcriptions are delayed

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 11:01 EST

Identified

Transcripts are now being processed
Posted Nov 11, 2025 - 09:33 EST

Update

There are delays creating video transcripts
Posted Nov 11, 2025 - 04:58 EST

Investigating

We are currently investigating this issue.
Posted Nov 11, 2025 - 04:57 EST