Upload Failures
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted almost 2 years ago. Apr 06, 2017 - 17:09 EDT
Monitoring
We implemented a fix and are monitoring to ensure stability. Please try your uploads again. Apologies for the inconvenience!
Posted almost 2 years ago. Apr 06, 2017 - 09:12 EDT
Investigating
We are currently experiencing issues with uploads. Our engineers are working to fix the issue as soon as possible, and we will post an update when things are back to normal.
Posted almost 2 years ago. Apr 06, 2017 - 08:07 EDT