AI and Create services unavailable

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 06:44 EDT

Update

We are currently experiencing technical difficulties with our AI and Create services due to an issue with one of our third-party service providers. Our technical team has identified the source of the problem and is working closely with the provider to restore full functionality as quickly as possible.
Posted Oct 20, 2025 - 05:26 EDT

Update

We are currently experiencing technical difficulties with our AI services due to an issue with one of our third-party service providers. Our technical team has identified the source of the problem and is working closely with the provider to restore full functionality as quickly as possible.
Posted Oct 20, 2025 - 04:09 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 03:55 EDT