Intermittent outages
Incident Report for Vimeo
Resolved
Thank you for your patience! Our engineers were able to resolve this issue and the site should be operating normally.
Posted over 2 years ago. Nov 21, 2016 - 20:01 EST
Monitoring
The site is now stable, however, we are continuing to monitor its performance. We'll provide another update once we are certain this issue is resolved.
Posted over 2 years ago. Nov 21, 2016 - 19:15 EST
Investigating
We are getting new reports of the site experiencing intermittent outages again. Our engineers are investigating this now so we can get it fixed ASAP!
Posted over 2 years ago. Nov 21, 2016 - 15:01 EST
Monitoring
Vimeo.com is back up and running. We're monitoring things to make sure we remain stable.
Posted over 2 years ago. Nov 21, 2016 - 13:03 EST
Investigating
We are currently aware that the Vimeo site is experiencing some intermittent issues at the moment. Our engineers are working on getting this resolved as soon as possible. We'll let everyone know once things are back to normal!
Posted over 2 years ago. Nov 21, 2016 - 12:33 EST