Issues with Vimeo Create services

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 16:20 EDT

Identified

We are seeing recovery with the Create services are are continuing to monitor
Posted Aug 05, 2026 - 16:00 EDT

Update

We are continuing to investigate the issue
Posted Aug 05, 2026 - 15:33 EDT

Update

We are investigating an issue with Vimeo Create
Posted Aug 05, 2026 - 15:24 EDT

Investigating

We are currently investigating this issue.
Posted Aug 05, 2026 - 15:23 EDT
This incident affected: Create.