Issues uploading

Incident Report for Vimeo

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 14:55 EDT

Identified

We have a fix in place, users should not be facing the issue anymore.
Posted Oct 14, 2025 - 14:50 EDT

Update

Some customers may see a spinner when trying to upload on vimeo.com
Posted Oct 14, 2025 - 14:35 EDT

Investigating

We are currently investigating this issue.
Posted Oct 14, 2025 - 14:34 EDT