Errors appearing when accessing Help Center (help.vimeo.com)
Incident Report for Vimeo
Resolved
We've identified the problem and have resolved the issue. Our support system and help center are now functioning normally.
Posted 11 months ago. Oct 15, 2018 - 09:43 EDT
Update
This issue is also affecting our main support system. We'll respond to all support inquiries as soon as possible.
Posted 11 months ago. Oct 15, 2018 - 08:22 EDT
Investigating
We are currently investigating an issue causing errors to appear when accessing our help center (help.vimeo.com). We will provide an update once we have more news to share. Thank you for your patience and understanding.

If you are having trouble contacting us, please visit https://vimeo.com/help/contact.
Posted 11 months ago. Oct 15, 2018 - 07:48 EDT
This incident affected: Support Systems.