Vimeo Site Outage
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 18:07 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2019 - 17:38 EST
Investigating
We are investigating an intermittent issue on Vimeo. This may affect your ability to access your account, and your content.
We will update within 30 minutes or upon resolution.
Posted Nov 15, 2019 - 17:24 EST
This incident affected: Website and API.