Site Not Loading
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 17:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2021 - 17:42 EDT
Investigating
We are currently investigating an issue impacting the Vimeo site, player, and API. We are actively investigating this issue and will update the status as more information is available.
Posted Jul 19, 2021 - 17:29 EDT
This incident affected: Website, On-Site Player, Embedded Player, and API.