Unlisted links result in blank page for logged out users
Incident Report for Vimeo
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 22:38 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 22, 2024 - 22:06 EST
Investigating
Unlisted links result in blank page for logged out users. Our team is currently investigating. The workaround for now is to log into Vimeo or change the privacy to anything other than unlisted.
Posted Feb 22, 2024 - 20:19 EST
This incident affected: Website.