Delays in Processing Uploads

Incident Report for Vimeo

Resolved

We have recovered the affected videos and systems are operating normally.
Posted Jul 19, 2025 - 18:00 EDT

Update

Our team continues to work on recovering some videos that were uploaded between 2:56 EDT and 12:21 EDT that are experiencing a playback error. New Uploads after that period are unaffected.
Posted Jul 19, 2025 - 16:24 EDT

Update

Impacted uploads from earlier have completed processing but are resulting in a player error as we continue to recover those.
Posted Jul 19, 2025 - 13:52 EDT

Monitoring

Upload processing has been restored but there are some residual delays while we process the backlog.
Posted Jul 19, 2025 - 13:24 EDT

Investigating

We're investigating an issue where uploads are delayed.
Posted Jul 19, 2025 - 13:20 EDT

Monitoring

We have implemented a fix, though any uploads between 2:56 EDT and 12:21 EDT that are still processing may take additional time to recover.
Posted Jul 19, 2025 - 12:28 EDT

Investigating

We are currently investigating an issue with processing uploads.
Posted Jul 19, 2025 - 12:19 EDT
This incident affected: Upload.